1

I am getting this error while creating the scratch org: [![enter image description here][1]][1]

{
  "status": 1,
  "name": "ProblemDeployingSettings",
  "message": "Failed to deploy settings to scratch org.",
  "exitCode": 1,
  "commandName": "OrgCreateCommand",

enter image description here ========== My DEF FILE ===========

{
    "orgName": "BUBBA TEST",
    "edition": "Enterprise",
    "features": ["ContactsToMultipleAccounts", "DeferSharingCalc", "PersonAccounts"],
    "settings": {
        "chatterSettings": {
            "enableChatter": false
        },
        "enhancedNotesSettings": {
            "enableEnhancedNotes": true
        },
        "nameSettings": {
            "enableMiddleName": true,
            "enableNameSuffix": true
        },        
        "opportunitySettings": {
            "enableOpportunityTeam": true
        },
        "quoteSettings": {
            "enableQuote": false
        }
    }
}

Can anyone help me understand what's causing this?

  • 1
    What's the sourceApiVersion in your sfdx-project.json ? Can you try with API 48 if it's something different ? I tried with the same definition file and I can create the scratch org without any error. – Fabien Taillon Mar 21 at 12:27
  • Does the error repeat if you retry? – David Reed Mar 21 at 15:34
  • Thanks for the response(s) It does keep throwing same error even after setting the ApiVersion in sfdx-project.json to 48. – Kvin Cloud Mar 21 at 16:56
  • @DavidReed yes, It repeats every time I try from windows. The funny thing is - it worked fine when I created scratch with same definition file and same version of CLI 7.50.0 from MacOS. – Kvin Cloud Mar 21 at 19:37
5

For anyone struggling with the same above mentioned error while creating scratch org, I was able to create scratch org by downgrading my salesforcedx plugin version to : salesforcedx 47.18.0 (47.18.0) instead of latest at this moment(salesforcedx 48.5.1)

sfdx plugins:install salesforcedx@47.18.0
| improve this answer | |
  • hmm, here I am on sfdx-cli 7.61.0, and I went ahead and rolled back my plugins to 47.18 as suggested.. but.. no luck – bkwdesign Jun 4 at 20:37
  • Well, I have tried this option as well - re-install the CLI and it may fix this – Kvin Cloud Jun 5 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.