-1
global class PbxmlGroupProvider extends DataSource.Provider {

    override global List<DataSource.AuthenticationCapability> getAuthenticationCapabilities() {
        List<DataSource.AuthenticationCapability> capabilities = new List<DataSource.AuthenticationCapability>();
        capabilities.add(DataSource.AuthenticationCapability.ANONYMOUS);
        capabilities.add(DataSource.AuthenticationCapability.BASIC);
        return capabilities;
    }

    override global List<DataSource.Capability> getCapabilities() {
        List<DataSource.Capability> capabilities = new List<DataSource.Capability>();

        capabilities.add(DataSource.Capability.ROW_QUERY);
        capabilities.add(DataSource.Capability.SEARCH);
        return capabilities;
    }

    override global DataSource.Connection getConnection(DataSource.ConnectionParams connectionParams) {
        return new PbxmlGroupConnection(connectionParams);
    }
}

1 Answer 1

0

The error message explains that the class PbxmlGroupConnection does not have this constructor:

global PbxmlGroupConnection {

    global PbxmlGroupConnection(DataSource.ConnectionParams connectionParams) {
        ...
    }

    ...
}

but you are trying to call that constructor here:

        return new PbxmlGroupConnection(connectionParams);

So either change the calling code to use or change that class to fix this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.