0

I have retrieved source with a package.xml which includes following segment

 <types>
    <members>*</members>
    <name>Settings</name>
 </types>
 <version>48.0</version>

Then converted source into metadata format. When I try to deploy metadata with generated package.xml, deployment fails with error Unknown type name 'SurveySettings' specified in package.xml

Once I retrieve data a folder called 'surveySettings' was created and generated package.xml contains following segment.

<types>
    <name>SurveySettings</name>
    <members>Survey</members>
</types>

Any help would be appreciated.

  • Where are you deploying to? Do you need these settings? – sfdcfox Mar 13 at 2:53
  • I'm deploying to a sandbox. I'm just trying to migrate to metadata deployment. Currently, we do not have the source for this org. So that I need to retrieve all the source files first. Then tried to deploy it again to the same sandbox. Actually I don't need this. But I think if I don't mention it on retrieve package, I will miss some data. – Isuru Buddhika Herath Mar 13 at 2:58
0

The generated package XML looks incorrect. The correct package XML structure for Survey setting would be

<?xml version="1.0" encoding="UTF-8"?>
 <Package xmlns="http://soap.sforce.com/2006/04/metadata"> 
<types> 
<members>Survey</members>
 <name>Settings</name>
 </types> 
<version>47.0</version> 
</Package>

The retrieved and to be deployed file name should be Survey.Settings inside survey folder.

| improve this answer | |
  • That's make sense. But how do you avoid getting created these tags, because this package XML is generated with sfdx commands. – Isuru Buddhika Herath Mar 15 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.