0
  1. I logged in as System Admin and switch to app named "Acme Console"(blurred the actual name in screenshot but let's just assume that is the app name).
  2. I navigate to Order record detail page and click on setup icon and select "Edit Page" option and this is what I see. It tells me that I am on Lightning record page named "Order_Record_Page1".

    enter image description here

  3. I go to setup screen and see what all lightning pages are there for order object and I don't see a page named "Order_Record_Page1". Here is the screenshot.

    enter image description here

  4. I tried the option page assignments to see which lightning page is assigned for System Admin profile when using Acme console app and it doesn't show the page name but just says "System Default".

    enter image description here

My question is if I don't see a Lightning record page named "Order_Record_Page1" in step 3, why does it say that I am editing "Order_Record_Page1" in step 2.

EDIT: This is what I see when I query FlexiPage object in developer console using Tooling API and it shows that there is no FlexiPage named Order_Record_Page1

enter image description here

1

'Order_Record_Page1' doesn't exist in the database until you press save. What you are seeing is technically a cloned version of the standard (system default) out of the box page, all in your browser. "Order_Record_Page1" is a default generated name which will be used if you press save.

| improve this answer | |
1

I think you are confusing DeveloperName with Label. Most Salesforce setup objects have a DeveloperName which needs to be unique and can't contain spaces or special characters, whereas the Label can contain those things.

If you open developer console and run a query using the Tooling API, you can see both pretty easily.

select id, MasterLabel, DeveloperName from flexipage

| improve this answer | |
  • I queried FlexiPage object as you said for Order object and it shows only one record and the developername is different than what I see in step 2. I updated question with more details. – javanoob Mar 12 at 20:12
  • Have you ever saved the page? I think what is happening is that there is an out of the box page that is read only. When you click edit, it creates a new version and appends the 1. Looking in my org at Account, I have one page I can't edit. – Daniel Hoechst Mar 12 at 20:57
  • No, I didn’t save the page. But I think the same, when we do the Edit page from setup, it is creating a new page appened with “1”. – javanoob Mar 12 at 21:04
  • What Daniel is saying is correct. 'Order_Record_Page1' doesn't exist in the database until you press save. What you are seeing is technically a cloned version of the standard out of the box page, all in your browser. "Order_Record_Page1" is a default generated name which will be used if you press save. – Kristian Mar 16 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.