2

I created a Permission Set Group with one Muting Permission Set and was able to retrieve the metadata fine (using source:retrieve -m). However the metadata seems to only contain the name of the Muting Permission Set, not its content. So how do I retrieve the Muting permset itself? I don't see a new type in the MDAPI doc, and couldn't seem to be able to retrieve it as a regular permset (using the API name) either.

Edit: error message trying to retrieve MutingPermissionSet as suggested enter image description here

1

There's a metadata type available as of 46.0 called MutingPermissionSet that you need to retrieve as well.

| improve this answer | |
  • Is it only accessible via SOAP API at this point? I tried it with source:retrieve and ended up with "Cannot read property 'metadataName' of undefined", which usually means the MDAPI doesn't recognize the type. My sfdx core is at 48.4.1 so should be no version issue. – Bing Mar 6 at 22:34
  • That's odd. The metadata coverage report shows that it's supported by the MDAPI. And I was able to retrieve one using the Org Browser in vscode which runs force:source:retrieve.. – John Towers Mar 6 at 23:02
  • no dice... I tried Org Browser, and it ran the same command I did from the Terminal - (source:retrieve -m) and got the same result. – Bing Mar 9 at 3:46
  • Interesting. I just ran sfdx update and then tried the retrieve again and now it's failing with the same error you're seeing. Seems like something in an updated version may have broken this. Given the documentation, I don't see a reason why this shouldn't work. – John Towers Mar 9 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.