0

I set up an external ID on a custom object I set up a relationship on opportunities to reference that custom object I upsert the custom object (including the external id) I upsert the opportunities using the same field in the __r field as I did in the external ID

The problem is there is no link made between the opportunity and custom object. I have done this multiple times and it has just worked. This time it is not. What can I check to see if everything is set up correctly?

I am using jitterbit.

Externalidscreen

jitterbit mapping to opportunity

Thanks

6
  • Could you please edit your question to show us the upsert code you are using? Screenshots of the schema setup may also help.
    – David Reed
    Mar 6 '20 at 18:20
  • Let me know if I need to add more.
    – A Pierre
    Mar 6 '20 at 18:29
  • Which Salesforce API are you using for the upsert? Can you verify that the field is actually populated correctly when the request is sent to Salesforce? Typically when I run into this with jitterbit it's because I messed up a mapping and the external id looks mapped but doesn't actually get a value when the operation runs. Mar 6 '20 at 18:32
  • what doesnt get populated ? the external id in the opportunity (parent) or in the custom object (child)? How do I check which api. the external id did get loaded in the custom object.
    – A Pierre
    Mar 6 '20 at 18:35
  • Open your operation and look for the node that does the upsert. It should either be a bulk upsert (if you double click on it you will see a Salesforce Bulk Processes tab) or you will see an SFDC Upsert web service method (which uses the SOAP API). You should check both results to ensure that the custom object has the correct external id value and that the request for the Opportunity upsert sends the correct external id for the child object. Mar 6 '20 at 18:48
0

I solved this with your help. The external id on the opportunity was old. Everything was ok with the relationship. I was using an old mapping. Thank you for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.