2

How to create a scratch org from a snapshot with namespace? Any workaround or solution?

Error

{
  "status": 1,
  "name": "INVALID_INPUT",
  "message": "Unsupported snapshot signup request fields: Namespace.",
  "exitCode": 1,
  "commandName": "OrgCreateCommand",
  "stack": "INVALID_INPUT: Unsupported snapshot signup request fields: Namespace.\n    at HttpApi.getError (.local/share/sfdx/node_modules/jsforce/lib/http-api.js:250:13)\n    at .local/share/sfdx/node_modules/jsforce/lib/http-api.js:95:22\n    at tryCallOne (.local/share/sfdx/node_modules/promise/lib/core.js:37:12)\n    at .local/share/sfdx/node_modules/promise/lib/core.js:123:15\n    at flush (.local/share/sfdx/node_modules/asap/raw.js:50:29)\n    at process._tickCallback (internal/process/next_tick.js:61:11)\nOuter stack:\n    at Function.wrap (.local/share/sfdx/node_modules/salesforce-alm/node_modules/@salesforce/core/lib/sfdxError.js:151:27)\n    at OrgCreateCommand.catch (.local/share/sfdx/node_modules/salesforce-alm/dist/ToolbeltCommand.js:246:46)",
  "warnings": []
}

project-scratch-def.json

{
    "orgName": "MyOrgName",
    "namespace": "myNamespace",
    "snapshot": "mySnapshot"
}

I've created a snapshot from a scratch org with a namespace. So when trying to create a new scratch org from this snapshot, I expect to have the same namespace, but it doesn't work like that.

When removing the namespace or when adding the same namespace from the snapshot, the following error happens Unsupported snapshot signup request fields: Namespace.

When blanking out or sending null, it does create the scratch org, however with no namespace, and of course, nothing works as expected.

9
  • Just a heads-up, because Scratch Org Snapshots are not a public feature and in a limited pilot, expertise around here may be fairly limited. Is there a Chatter group for the pilot?
    – David Reed
    Mar 5, 2020 at 16:34
  • @DavidReed, fair point! Thanks for that! I just have joined the group "Pilot: Scratch Org Snapshots"! success.salesforce.com/_ui/core/chatter/groups/… Mar 5, 2020 at 17:09
  • If you do receive a solution there that's OK to share publicly, please post it as an answer!
    – David Reed
    Mar 5, 2020 at 17:32
  • I've confirmed that it's a known limitation of the pilot. So unfortunately at the moment, there is no workaround and it doesn't work. Mar 9, 2020 at 15:49
  • That's a shame but glad to know the situation - want to post an answer with the details you received?
    – David Reed
    Mar 9, 2020 at 15:54

0

You must log in to answer this question.