0

I encountered this error message recently in a function that had been okay before:

"First exception on row 0; first error: NO_APPLICABLE_PROCESS, No applicable approval process was found".

As the message says, there is an error in the approval process. However, I just cannot find a way to solve it. Has anyone had the same problem?

The timing happened to be around the 2020 Spring critical update at the end of February.

I have another error message about the approval process which also occurred after the critical update:

"Insert failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, XXXXXX: execution of AfterInsert caused by: System.DmlException: Process failed. First exception on row 0; first error: TEMPLATE_NOT_FOUND,...... "

Thanks.

3
  • 1
    I haven't run into that second error, but the first one is given when you submit record(s) for approval (button click in the UI, or via Apex), but at least one of them don't satisfy the entry criteria. Not sure how Spring '20 comes into play, but it's a place you can start looking for an answer. – Derek F Mar 3 '20 at 12:31
  • Hi Derek, yes you are right. The first one is a problem of entry criteria. Nothing to do with the critical update. The second one turned out to be also object access not granted to a profile. Thanks. – Zhuang Paulus Mar 3 '20 at 15:51
  • 2
    If you've figured it out, you should write up an answer detailing your debugging and how you went about fixing it so that this question can help other people with similar issues. – Derek F Mar 3 '20 at 16:18
1

I have solved the two problems. They have nothing to do with 2020 Spring critical update.

For the first one:

"First exception on row 0; first error: NO_APPLICABLE_PROCESS, No applicable approval process was found".

I did not meet the entry criteria for an approval process. A role that uses this approval process was not in the public group in the entry criteria.

For the second error message:

"Insert failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, XXXXXX: execution of AfterInsert caused by: System.DmlException: Process failed. First exception on row 0; first error: TEMPLATE_NOT_FOUND,...... "

This is because I did not grant view privilege to a object for a profile that uses this object in the process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.