I've been setting up an outbound message web service listener, I've not done this before and haven't worked with Tomcat either so this is all very new to me. I followed the instructions here wiki.developerforce.com/page/Creating_an_Outbound_Messaging_Notification_Service_with_Eclipse_3.2 and managed to get something together despite the instructions being a bit out of date.

Now, everything works fine if I run Tomcat through eclipse, it also works OK if I export the project as a WAR file and run tomcat through the command line, however both of these methods have the disadvantage of needing an application to be running. I set up the Tomcat service and got it running, however I now get "SOAP response was a nack" in Salesforce and my web service isn't working. I don't know what this message means and I don't understand why I only get it when tomcat runs as a service, because it only runs the WAR file and that works when I run through the command line. I should also add that I've not done anything related to responses in the code, so its set up however eclipse sets it up by following the instructions on the link I've provided, which is just a boolean I think.

Why am I now getting this error and how do I solve it? As I say I'm new to this kind of thing so instructions will have to be clear.


2 Answers 2


First make sure that your webservice itself is working correctly. Try by calling the webservice from a tool like SOAP UI and see if you get the response you expect. If not, you should first make sure your webservice functions correctly.

If your webservice is working correctly, it could be that your webservice is behind a firewall that is blocking Salesforce from calling the webservice. If that is the case, your IT will have to whitelist the Salesforce IP's.

  • I don't think the firewall will be the issue because I believe IT have already whitelisted SFDC IPs. I'll download SOAP UI and see what happens, I'm not really sure what response I'd expect though to be honest! I guess I could try when tomcat is running through CMD and then again when its running as a service and see if the response is different?
    – ministe
    Commented Mar 7, 2014 at 14:41
  • OK, not sure this is going to be any help because I get an entirely different error in SOAPUI. Not sure if I've set it up correctly but I now get "Fri Mar 07 15:42:17 GMT 2014:ERROR:An error occurred [Missing operation for soapAction [] and body element [{soap.sforce.com/2005/09/outbound}notifications] with SOAP Version [SOAP 1.1]], see error log for details"
    – ministe
    Commented Mar 7, 2014 at 15:44
  • You were able to go through the entire article right to setup the webservice? (like generate code in java based on the WSDL you got from the outbound message) I think you must have missed a step somewhere. It's indeed needed that the webservice is running on a tomcat server somewhere.
    – KoenVM
    Commented Mar 7, 2014 at 16:04
  • You mean the article in my original question. I followed all the steps and I do have my web service running on a tomcat server. As I say, it all works fine if I run tomcat through eclipse, or if I start it through CMD, but if I run the tomcat service, that's when I get the SOAP response was a nack error
    – ministe
    Commented Mar 7, 2014 at 16:09

Found the solution. Everything was fine, the issue was the running user of the Windows Service. I'm logged into the server as administrator so it didn't cross my mind that the service would have any rights issues, however when I entered the admin login details onto the service, suddenly everything started working!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .