I am unable to deploy unlocked packages created with SFDX/CLI . I am receiving the "The package version is not fully available. If this is a recently created package version, try again in a few minutes or contact the package publisher." error message via the CLI, hours and days after the package version has been created. I have tried creating new package versions, but still receive the same error when trying to install the package to a sandbox org. When trying to install the package via the Salesforce UI, the UI won't accept the package installation key.

Everything has been working fine for months, I'm not sure what changed that caused this to happen, but I have tried creating new versions and installing multiple packages that have been working fine.

  • They just deployed a bunch of "improvements" to the way Packages are created with version 48 for Spring 2020. Also you are writing this at the moment some orgs are v47 and other are v48. Start from scratch and try again, things will probably work. Feb 18, 2020 at 14:55
  • It sounds stupid but I had this happen to me once when using an 18 chr package version Id. As soon as I changed it to 15 chr Id it worked. Subsequent attempts to use 18 chr Id still gave same error. It might have been a bug at the time or some weird quirk but worth a shot
    – Eric
    Feb 18, 2020 at 15:06
  • @BillAppleton can you clarify what you mean by starting from scratch? Feb 18, 2020 at 20:53
  • Create the package again. Try to deploy again. Feb 19, 2020 at 13:41
  • @BillAppleton that works, but I don't think it's a viable workaround. I copied my project folder and created the package again with the name "My Package2" instead of "My Package". I then created a package version and tried to install it in a sandbox where "My Package" is already installed. This didn't work, probably because both packages have the same metadata. I was able to install in a another sandbox that didn't have "My Package" installed. I know I can manually disassociate each metadata item from "My Package", but to do this across multiple large packages in multiple orgs is painful. Feb 19, 2020 at 15:24


You must log in to answer this question.

Browse other questions tagged .