2

I have a Workflow Rule set up to send an Outbound Message every time a Lead is edited. We evaluate the rule when a record is: "created, and every time it's edited". The Rule Criteria is set to Field: Lead:Zip Code, Operator: not equal to, Value: 00000 (I want this rule to fire an outbound message each and every time a Lead is edited).

The Outbound Message is pretty standard. Just hits our endpoint URL and "Send Session ID" box is ticked. We are just sending the Id.

After I activate this rule and try to test it by editing a lead, we never see our URL getting hit.

When I check the delivery status in Outbound Messages>View Message Delivery Status, there are no messages at all.

I have searched for an answer, and while there are good questions and answers about Outbound Messages being lost, ours are not lost, they appear to never send in the first place.

Any ideas on what I am missing?

UPDATE - Here is the log from the Developer Console. It appears that the rule requirements are met and the message fired. enter image description here

UPDATE SOLVED - Getting the message to fire every time with NOT(ISBLANK(Name)) worked great. We also had a issue with the URL we were hitting silently failing. Best thing was seeing the workings in the Developers Console. That was a great tip.

  • 2
    Did you activate the rule? – superfell Mar 5 '14 at 17:57
  • Yep Activated the Rule. Spent around 10 mins head scratching before I thought of that. But once I activated it, nothing still. – Joshua Dance Mar 5 '14 at 18:14
  • 2
    Try change criteria to for example NOT(ISBLANK(Name)). Then open debug, update record and check debug log. If it still won't work please provide us with this log – Artur Kępczyński Mar 5 '14 at 18:23
  • Went to Setup>Monitor>Logs>Debug Logs and there is nothing there. I also went to the Developer Console. My WF_CRITERIA_END evaluates to True on the Last Name not being blank. I'll post the log. – Joshua Dance Mar 5 '14 at 18:43
  • Messages are going thru. Thanks for all the help. I will update my q with info we found. – Joshua Dance Mar 5 '14 at 18:59
2

Lets do some guess here:

1) Do you have all as per this doc : https://www.salesforce.com/us/developer/docs/api/Content/sforce_api_om_outboundmessaging_setting_up.htm

There is a line that says "

If you do not have these options, your organization does not have outbound messaging enabled. Contact salesforce.com to enable outbound messaging for your organization.

" so I have a feeling that outbound message needs to be activated for your org. ( I could be wrong here since you seem to have setup everything, just writing this since it might be a good reference for others to follow)

2) As per Daniel's blog :

http://www.fishofprey.com/2011/08/salesforce-outbound-messages-not-being.html

It looks like the user needs to have

Administrative Permissions: Send Outbound Messages

check if this is enabled on the user profile. If you are sending it as a sys admin ( beware I have seen orgs cloning standard profiles and renaming to create a custom profile, so if you are standard sys admin and not a custom one) you should have it by default.

  • 1
    @joshuaDance what solved your issue, was it the permission/ org was not enabled with outbound message. It would be helpful if you can point that out for site visitors if they are struck with the same issue. – Rao Mar 5 '14 at 19:00
  • Great idea @rao. Done. :) – Joshua Dance Mar 5 '14 at 20:45
0

Cloudflare's browser integrity check could cause the issue.

So if you use cloudflare for your endpoint, make sure to turn that setting off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.