0

I've linked namespace, set up sfdx-project.json

{
    "packageDirectories": 
    [
        {
        "path": "force-app",
        "default": true
        }
    ],
    "namespace": "vpv",
    "sfdcLoginUrl": "https://login.salesforce.com",
    "sourceApiVersion": "47.0"
}

But when I try to create scratch I've got an error:

We don’t recognize this namespace: vpv. Did you register it in your Dev Hub org?

What am I doing wrong?

  • Of course I've linked namespace – pincet Feb 10 at 8:54
  • 2
    Well, the message points to that process not having worked or that you are connected to the wrong dev hub... So double-check. – Keith C Feb 10 at 9:15
  • sdfx force:org:list says me that my DevHub is (D) - default. What can be wrong with process? – pincet Feb 10 at 10:05
  • 2
    Your dev hub can be set to something else for the current directory, or based on the CLI args you used. So, it can be in ./.sfdx/sfdx-config.json under the "defaultdevhubusername" key, or it can be via the --targetdevhubusername or -v flag on the CLI command – Aidan Feb 10 at 10:10
  • 2
    That just points back to Keith's original suggestion. Either you did not successfully complete the namespace linking process, or you did complete it but in a different Dev Hub. You can verify by looking at the Namespace Registries records in your Dev Hub, which should list your namespace if linked. – David Reed Feb 10 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.