0

In Einstein Analytics, the synchronization of the User Object is failing due to the following error:

Something went wrong while executing the Sync_User node: Field [UserPermissionsMobileUser] is not available. Verify that the field exists and that the Analytics Cloud Integration User profile has Read level access on the field.

In field level Security, the UserPermissionsMobileUser field is not listed, so I cannot change the access for the integration user.

The error appeared as Salesforce upgraded to release Spring 20 and has not occured before. Maybe it has something to do with the "New Salesforce Mobile App", but I would not know for sure.

0

I am also encountering almost the same issue - Flow is throwing an error due to unrecognizable criteria: UserPermissionsMobileUser.

As per this article: https://releasenotes.docs.salesforce.com/en-us/spring20/release-notes/rn_mobile_app_new_welcome.htm "The new Salesforce mobile app is yours, automatically. You don’t have to turn on your Lightning Experience org preference or assign the New Salesforce Mobile App user permission to access the new app admin or end-user experience."

We started encountering Flow errors on the 17th of February 2020 which is the date when the New Salesforce Mobile App Feature was released.

I am hoping that Salesforce will release an update or their plans about UserPermissionsMobileUser.

| improve this answer | |
  • Hi John, we reported that issue to Salesforce and they implemented a workaround until the next release. I think they excluded the field from synchronizing... – user40501 Mar 4 at 15:42
  • Thank you, @user40501 - I just got a confirmation from Salesforce Support that UserPermissionsMobileUser has been taken out from the system but is still visible on the UI. Article: releasenotes.docs.salesforce.com/en-us/spring20/release-notes/… – John Mar 9 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.