0

I have embedded the flow in a community template. The flow is accessible to the guest users, however flow does not work as expected e.g. it would not find records using the Get record element in flow. When I run it in salesforce, it seems to work fine. Not sure why it does not work when I run it in the community as a site guest user.

Thanks

  • 1
    Does the community user have access to the records you're trying to get in the flow? – Kris Goncalves Feb 7 at 19:32
  • oh I just noticed default external access in org wide sharing settings is private. Do I need to change it to public read? – Anonymous Feb 7 at 19:39
  • 1
    if you change it to public, you will see an SFDC Health Check warning when you run that in Security Settings. You are better off with explicit sharing rules or sharing sets – cropredy Feb 7 at 20:23
  • I did change the org wide defaults for external users to 'public' to test this. It still does not work as expected. – Anonymous Feb 7 at 22:25
1

There's a specific profile for Guest Users. If you give that profile access to the objects you want to expose, the Flow will work as expected.

Main docs are here.

A lot of things changed in Winter '20, so read up here.

| improve this answer | |
  • Yes after giving the guest profile access to objects, setting org wide default settings and giving user "Run flow" permission, it worked fine. – Anonymous Feb 14 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.