1

Anyone ever run into this issue? Here’s what happened. Salesforce connector just finished integration last week. Everything worked - I set up objects to sync, they were syncing just fine (synchronized data extensions were created and populating). Then, for some reason it stopped working due to a number of IP addresses not being whitelisted.

No objects would sync and we could not add new objects.

I had client whitelist all IPs, and then after sometime, still not working, going into Salesforce Integration, we see this. Account is disconnected. Customer goes to reconnect and inputs the sales cloud credentials and gets this error. enter image description here

  • 3
    You would be missing a setup process or a potential configuration that was missed, I would re-run through the entire configuration process step by step from the following documentation: help.salesforce.com/…, this should fix your issue, the errors in Marketing Cloud are too vague to perform a process of elimination so therefore it will be quicker to re-run through the setup process. – thechrishaddad Jan 24 at 3:22
  • I agree with @thechrishaddad that it's likely a misstep in configuration. I'd also recommend the trailhead for this module in addition to the docs they posted trailhead.salesforce.com/en/content/learn/modules/…. As a side note, I've encountered this before as well and resetting the connector resolved the issue. – Jason Hanshaw Jan 24 at 4:04
  • I had the same problem last month: salesforce.stackexchange.com/questions/289177/… – zuzannamj Jan 24 at 9:12
5

There are 3 common causes for such error messages

1- ConnectedApp Authentication is not properly configured in Sales Cloud

2- The Salesforce System user does not have the correct configuration

3- There are IP restrictions in place within the Org or the IP Ranges for Salesforce Managed Packages have not been whitelisted

4- (Less likely)- The "Is Sandbox" checkbox is not checked if Connecting to Sandbox environment.

I hope that helps. Cheers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.