2

Background

Our SBQQ__Quote__c record page utilizes the QuoteSave VF page. As I understand it, this page polls for the underlying asynchronous job and indicates whether the job is complete.

In some online sources, there are suggestions that the VF page should trigger a refresh once the async process is complete but we haven't observed this.

Steps to Reproduce

In Lightning, on a CPQ Quote, click the Clone with Related button (Lightning version of the button). Accept the defaults on the Related Items Preview page. Continue to Clone the quote.

The system then redirects the user to the Quote page, but the QuoteSave VF page is spinning. Wait for the spinner complete and the VF widget to clear.

Double-click on a field and inline edit a field on the page.

Receive error:

What We've Tried

The only workaround we have found so far is to refresh the page once it's done calculating. This is not a viable solution.

We also tried setting the SBQQ__LastCalculatedOn__c field (in hopes of turning SBQQ__Uncalculated__c to false) in a before insert trigger on the Quote, but this does not suppress the calculation.

We ultimately need this solved, but for now we would be happy to simply suppress the recalculation at this point.

Thanks in advance.

1 Answer 1

0

According to Support, the correct workflow in CPQ is as follows:

  1. Clone the Quote and have it bring you to the Quote record page.
  2. Wait for the embedded QuoteSave VF panel to indicate background processing is complete.
  3. Refresh the page.
  4. Begin working with the Quote.

It's somewhat inconceivable that that is what they want us to do, but that's the official answer.

In our case though, we found that even when going through this process, we still encounter the collision error.

The best workaround we found was to have users use the Edit button rather than inline editing, which users have reported does not cause this issue.

Note in this case I am only using Clone as an example, we have a similar problem with our create-quote process, which is custom.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .