I'm interested in finding images that I have put into Content Builder based on their url but I'm having trouble retrieving the image name when I provide the publishedURL. I am able to do the reverse and get the publishedURL with ease so I'm wondering why get an empty set of items when retrieving by publishedURL.

Here is my REST call is as follows:

POST /asset/v1/content/assets/query
Host: https://www.exacttargetapis.com
Authorization: Bearer {{authToken}}
Content-Type: application/json

    "page": {
        "page": 1,
        "pageSize": 50
    "query": {
       "property": "fileProperties.publishedURL",
            "simpleOperator": "equal",
            "value": "http://image.wateremail.com/lib/fe9315707063077e7c/m/3/f6b97037-587f-4e31-ab5a-973a7c84e99f.jpg"
    "fields": [
    "sort": [
            "property": "name",
            "direction": "ASC"

I get a 200 Success Response and the following when I make this call

    "count": 0,
    "page": 0,
    "pageSize": 0,
    "links": {},
    "items": []

However, when I do a substitution of the "query" portion (see below) and look for the publishedURL by querying again fileProperties.fileName of the image I get back the expected results with all columns I specify under fileProperties.

query": {
            "property": "fileProperties.fileName",
            "simpleOperator": "equal",
            "value": "feedback.jpg"

What could be the cause for the blank data response? Is fileProperties.publishedURL retrievable using simpleOperator? I also tried 'contains' instead of 'equal' but it retrieve a set images completely unrelated to my url path.

  • Oddly if you change equal to contains or like, it will return results (just not really helpful results). So it obviously does accept that as a viable query. I even tried escaping the url in case it was reading the https:// as a JS comment or something. No good. I am stumped on this. I feel like it has something to do with the way the url is stored or passed, but without further info I can't really figure it out. Jan 16, 2020 at 17:50
  • Try mustcontain instead of equal and see this thread. salesforce.stackexchange.com/questions/341895/… Aug 22, 2022 at 23:28


You must log in to answer this question.

Browse other questions tagged .