I having trouble to create the Refresh Token.

I want to give it to a third party, So it can use it to get an access token and send us data using an exposing web service that I created.

I tried to do the following steps :

  1. I created a Connected App.

  2. I gave the right OAuth Scopes.

  3. Defined a Callback URL.

  4. Open a web browser with the follwoing URL :

https://test.salesforce.com/services/oauth2/authorize?response_type=code&client_id=3MVG9llQY5kM..... &​redirect_uri=https://mySandbox.cs108.my.salesforce.com/services/oauth2/authorize

  1. Got the mismatch Error :


The Url that gave the mismatch is :


Inside my connected App - the Callback URL is exactly the same as the requested URI + I waited 24 hours and not just 10 min for the connected App to be available.

enter image description here

I also tried to add the scope param as : scope=refresh_token , but it give me the same error.

I also tried to do it from my domain since it enabled - but same response. The prevent "test.salesforce" is not checked anyway.

enter image description here

What am I doing wrong?


  • salesforce.stackexchange.com/questions/279466/… - is My Domain enabled?
    – Ayub
    Jan 9, 2020 at 8:45
  • Ayub thanks for responding. I just checked it and updated my answer - spoiler - same response - unfortunately
    – Salvation
    Jan 9, 2020 at 8:55
  • I'm wondering if you have enabled then why still cs108 is in url ... please recheck your url?
    – Ayub
    Jan 9, 2020 at 9:35
  • Hi Ayub, I updated the Pic of the My domain.. It has cs108 there also...
    – Salvation
    Jan 9, 2020 at 9:41


You must log in to answer this question.

Browse other questions tagged .