2

In Professional Edition, after the Spring '20 release, I'm not able to save any lightning component. Getting the below attached error. Anyone else facing a similar issue?

Error message:

nested exception is: common.exception.ApiQueryException: select Id from Site ^ ERROR at Row:1:Column:16 sObject type 'Site' is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names.: Source

enter image description here

Update 15/Jan/2020: Tried the following so far:

  1. Cloned the existing sandbox but still getting same error.

  2. Created a new sandbox with Winter '20 able to save lightning component but getting same error while deploying via Change Sets to Spring '20 sandbox.

enter image description here

  • Did Professional Edition allow for Lightning aura components before Spring '20? I know they don't allow Apex code, but I personally never tried a lightning component... – Bow-chicawow-ers Jan 9 at 5:25
  • 1
    Yes, all was working fine few days back, lightning components are allowed in Professional Edition but not apex. – manubkk Jan 9 at 6:14
  • maybe they realized that they could be interdependent and took it down 🧐 – Ronnie Jan 10 at 20:55
  • 1
    @Ronnie I did not try deploying again because I am not able to make any changes in the sandbox. – manubkk Jan 13 at 2:20
  • 1
    @Ronnie it is CS76 sandbox instance in the screenshot address bar. – manubkk Jan 13 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.