0

I am currently running Salesforce CLI version 6.44.0. When I configure the project in VS code then face an error that mentioned in heading of this question. In order to resolve the error, I updated cli version to latest one using command sfdx update.

When I configure the project then face the same error which I mentioned in below link:

SFDX 6.21.0-9db990b3c9 AND CURRENT Update - Error - sfdx no longer works

As per solution mentioned in above link I have to delete the data present in client folder, if I do that then again it reverts to the original version which I installed earlier and if I try to configure the project then same error comes mentioned in heading.

OS version: Windows 10 64 bit OS

Error: if I am using 6.44. Version of CLI then while creating a project in VS code I get an Error Specify Valid Template.

Command that I am running in VS CODE is

sfdx:force:project:create —projectname name —outputdir path —Template standard —manifest

If I upgrade the version to latest one and try to create project in VS code then i get the similar error mentioned in below link description

SFDX 6.21.0-9db990b3c9 AND CURRENT Update - Error - sfdx no longer works

Can someone please tell me how to get rid of this error

  • What error are you getting specifically? What command are you running? What OS are you using? The more information we have, the better we can help you. Please edit your question to include all the information you can. – sfdcfox Jan 7 '20 at 14:02
  • Updated description.please check – Dhananjay Patil Jan 7 '20 at 14:17
0

After installing Salesforce DX plugin, it is now working for me with the updated version and I am able to create the project.

Below is the command I run:

Sfdx plugins:install salesforcedx 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.