1

Im am currently trying to develop using scratch orgs, but i am having a strange issue. I keep getting the message "Scratch org sign up failed, daily scratch org limit reached".

The problem is, the limit is not reached. If i use force:limits:api display i got 80 remaining orgs. I also have more dev hubs and this error displays on all of them.

If i understand correctly, the dev hub used to create the default org is whatever is in sfdx-config, unless you use the -u parameter to specifiy another, right? If true, i tried 5-6 different hubs and i still get this error.

Any help would be greatly appreciated.

2

sfdx force:org:create takes the -v argument (not -u) to specify a Dev Hub.

I suspect that your default Dev Hub has hit its limit, while others may or may not have, but your scratch org requests aren't being routed where you intend them to. Check which Dev Hub is default by running sfdx force:org:list (it has the (D) annotation), and ensure that you use the right option to route to another Dev Hub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.