I've been coding Apex alone but now other developers will be involved so I am thinking about class naming conventions. This is what I was using:
Test class: ClassNameTest
Controller test class: ClassNameControllerTest
Web service class: ClassNameService
Web service test class: ClassNameServiceTest
1. Is it good/bad?
2. What is the convention for utility class that contains static methods?
3. Should I add "Trigger" at the and of trigger class name? Some people suggest doing this but triggers are in a separate package with ".trigger" at the end so I find it not needed. Am I wrong?
4. What whould be the naming convention for the instance class which object exists inside controller class?