3

I am at the last step of this superbadge and am getting the following error when I check step 10: enter image description here

From the lightning app builder the Map component is clearly available and already exists on the page I created. enter image description here

Here is the Friends_With_Boats Flexipage displaying the Map component with results. enter image description here

Has anyone else bumped into this issue? I am at a loss as to what to do next except maybe wait a few hours then click the button again to see if this issue resolves itself...

  • 1
    Did you check to make sure the component's name is exactly as written in the trailhead module? If the name doesn't match, it won't find it. – sfdcfox Dec 28 '19 at 16:33
  • 1
    The map component was the one component that was included with the unmanaged package deployed when this project was launched. "The Map component and its controller were included in the unmanaged package that you installed as part of the prework for this superbadge, so you only need to make a few changes." I just read through the last steps again and there is no instruction to rename it. – Kevin Dec 28 '19 at 16:47
  • This is what I have to make it available: <aura:component implements="force:appHostable,flexipage:availableForAllPageTypes" access="global" > – Kevin Dec 28 '19 at 16:53
2

So the issue had nothing to do with the error message reported.

In order to trouble-shoot the issue I changed the PlotMapMarker.evt from 'APPLICATION' to 'COMPONENT' then hit submit on item 10. This time I received a message that the PlotMapMarker.evt wasn't configured correctly, which is as one would expect. From there I continued down the path of incorrectness, updating the BoatTile.cmp and its controller to handle a component event instead of an application event. I then hit submit again. The message I received was that the BoatTile.cmp wasn't registering the PlotMapMarker.evt. So then I looked over what was in that line and discovered that I had type="{!c.PlotMapMarker}" instead of type="{!c:PlotMapMarker} I corrected the typo, reverted the event back to application, reconfigured the BoatTile component controller to process the app event and that did it.

| improve this answer | |
  • I have the exact same issue as you posted. Your comment didn't work for me. I tried what you did but its still the same. I'm not sure what's wrong, the names match the trailhead and I see the Map component on the Lightning App builder. Any other approaches you tried? – Anurag Jan 31 at 16:53
  • Hey Anurag, All I can recommend is to look for proper use of punctuation and capitalization. If the behavior is correct I think it would be the most likely culprit. I would start reviewing all of the items where c is used since that can be either '.' or ':' and make sure you have the right context being used. – Kevin Feb 4 at 3:30
0

Another important note to add is that the superbadge's scenario doesn't include the requirement to make it app hostable. So, it's worth it to remove the force:appHostable from the implements declaration.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.