1

I have an file drop automation set up to import files dropped in a specific folder on the FTP. These files are very large and take a while to import so I have enabled queuing on the automation.

The problem I am facing is that although the next runs queue up correctly they are eventually skipped and those files are never imported. Is there a way to prevent this or some sort of work around? I don't know the names of the files beforehand so I cannot set up listener automations for specific files names.

  • Are there any Errors in import notification? ... Did you try to manually import the file, to check if the file has any errors?... also can you confirm the import type is correct, such as 'Add and update' – Vishal Kumar C V Dec 27 '19 at 7:38
  • Hi Brett - is there any type of conformity with the file naming conventions? Do the files always get dropped into the same folder and end in ".CSV"? – Cameron Robert Dec 28 '19 at 22:22
  • Could you please confirm your "advanced file options" are not set to skip the file after a period of time completes (import configuration)? => "Skip if last import occurred less than the following number of hours ago" – jc_mc Jan 2 at 8:26
0

It sounds like you have the update type as Add or Update and rows or records are being skipped on import. If there are validation errors, there should be a results log file produced in the sFTP. If the records are only skipped, then no results file is generated.

You should also check if your file has bad data because those are skipped in the Import Activity as well.

By default, the import activity skips rows with bad data and imports the rest of the file.

A workaround can involve changing the import type to Overwrite.

Also I am making the assumption that you are importing into a data extension. If importing into a list and the file size is over 500,000 records, you’re going to run into issues especially if it’s an Add/Update. Data extension imports, on the other hand, can handle millions of rows of records without any issues.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.