2

I am trying to run a hellow world app in LWC open source and after "npx create-lwc-app my-app" when I cd in the dir and run "npm run watch" I get the below error.

E:\Development\LWC\workspace\dev>npm run watch

> [email protected] watch E:\Development\LWC\workspace\dev
> lwc-services watch

'lwc-services' is not recognized as an internal or external command,
operable program or batch file.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] watch: `lwc-services watch`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] watch script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ABC\AppData\Roaming\npm-cache\_logs\2019-12-24T16_31_47_970Z-debug.log

Have tried to install "npm install --global --production windows-build-tools" again, reistalled the nmp but still not working.

2 Answers 2

0

This thread on Github might help you: https://github.com/muenzpraeger/create-lwc-app/issues/70

1
  • 1
    Welcome to Salesforce SE! While this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – identigral
    Dec 26, 2019 at 21:06
0

Install lwc-services by running the command 'npm i lwc-services' and then run 'npm run watch'.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .