4

I'm stuck in the middle of switching from single-org to multi org.

In Marketing Cloud Setup > Salesforce Integration, I am getting the following error:

An exception occurred while saving the integration.

enter image description here

I am aware that it usually has something to do with the Sales Cloud API user's permissions, so I verified that the following:

  • Marketing Cloud Connected App permission set has been assigned
  • Marketing Cloud for AppExchange Admin flag is checked on user
  • Marketing Cloud for AppExchange User flag is also checked

I cleared out user mappings and OAuth tokens in Sales Cloud for all my API users. Didn't have any problems with establishing the connection from Sales Cloud to Marketing Cloud.

I also verified that we have white-listed all Salesforce IP ranges for the Salesforce integration.

Any clues what might be missing here?

6
  • Have you tried manually assigning the two tracking folders at the bottom in the 'Marketing Cloud Settings' section? Dec 23, 2019 at 19:20
  • This Official documentation might help... help.salesforce.com/… Dec 24, 2019 at 8:17
  • Thanks Anon and Vishal, those didn’t help.
    – zuzannamj
    Dec 26, 2019 at 20:06
  • Tough one to say. If the account was already integrated previously I would make sure that all users in Marketing Cloud are no longer mapped to Sales Cloud users before trying the connection again. Also, are you using the credentials of your designated system user to log in, instead of letting it auto-match based on the account you're currently logged in with? Definitely have the permission set assigned to that system user? Dec 26, 2019 at 21:22
  • @zuzannamj I am not sure... But just I was researching on this issue and came accross TOKENS. Does this anything to do with clearing old/invalid TOKENS! ... help.salesforce.com/… Dec 31, 2019 at 12:20

3 Answers 3

7
+50

I've seen this error a bunch of times and the only solution that has worked 100% of the time is to delete the package and reinstall. But you should follow these steps below before deleting and reinstalling the managed package (it helps to use an incognito window of Chrome as you may have other instances of CRM or MC open):

  1. You mentioned that you checked the permissions. Double check that the authentication settings are correct in CRM. And double check that you have applied admin permissions.
  2. Check the Permission Sets are assigned correctly to the correct user
  3. Also in CRM, you should be able to click the Connect to Marketing Cloud blue button.
  4. Theoretically, the Setup Wizard should create the connection and add the whitelist IP addresses automatically.
  5. If you're unable to get into the configuration settings, use this URL hack and add "apex/marketingcloudconfiguration" at the end of your URL. i.e. https://etxxxx.xxxx.visual.force.com/apex/marketingcloudconfiguration. Marketing Cloud Connector Settings
  6. Refer to the image above: Under Manage Business Units, make sure you have the business unit checked
  7. Under Manage Users, make sure you have your MC user checked for both User and Admin.
  8. In Marketing Cloud > Setup > Users, click the "Integrate" link and add your CRM login and save it so it shows Integrated.

Integrated User

  1. Back in CRM, in the Marketing Cloud Connector Settings, check that the API User Username matches your MC User. If not, then click the Change API User link.

API User Username

  1. If all else fails, delete the managed package and re-install the managed package.

I would make sure you try all the steps above before deleted and re-installing (I have a feeling it could be #2 above). But since you are on multi-org, I assume that this managed package is a fresh install in the org and it should not be an issue to delete the package and reinstall it.

4
  • Thank you @Jackson, I tried everything from your list, but unfortunately still no luck. Permission sets are fine. I also opened a case with support, but they take ages to respond, so if nothing else works, I will probably have to reinstall the managed package as you suggested.
    – zuzannamj
    Dec 27, 2019 at 15:13
  • 2
    I didn't have to reinstall the package in the end and all the settings on SFMC and SFSC side were correct - support said that it was something on their side and now they fixed it - but I think your tips will be beneficial for anyone who might encounter this error in the future - thanks!
    – zuzannamj
    Jan 2, 2020 at 8:54
  • FWIW, I'd skipped the step about creating an empty permission set - somehow in the first pass via Trailhead I'd missed the bit where said set gets linked to the connected app.
    – Matt Lacey
    Sep 20, 2021 at 11:03
  • Thank you for the insight @MattLacey Sep 20, 2021 at 19:04
2

I ended up creating a support ticket. Support said that all the settings on our side were correct and that the fault was on their side. They told me that they had to "reset the servers", which sounds very vague, but in the end it worked and I was able to connect all accounts successfully.

0

I faced the same issue and the below steps worked for me.

This issue occurred when I was logout from SF org and trying to connect from Marketing Cloud. To resolve the issue I first logged in into my SF org and clicked on 'Connect Account' button, this way it did not ask for credentials and used the active SF session running in the same browser. Hope this will help others.

1
  • Yep I mentioned in my answer to use a fresh incognito window so that you don't have any sessions open Jun 2 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.