1

I use Salesforce Data in all my Journeys and today I have realized that although in the tracking information there is no fail in History even though there are some failed emails.

I have different contacts from Salesforce which have received single emails but each time they access to a journey and the system tried to send them an email, it fails. I have tried to Preview and Test the email with Journey Data Extension (selecting the contact) and all Personalizations Strings are working properly so I don't know why the email fails.

Can somebody help me to understand why the email failed? Is there a way to know why the email send is failed?

5
  • This could occur when sending to invalid or corrupted email address.
    – jc_mc
    Commented Dec 20, 2019 at 15:21
  • jclobro thanks for your answer. The weird thing is that when we send a single email to that person it is received with no problem :( Commented Dec 20, 2019 at 15:27
  • Do you have more than 1 email field in the related data extension by any chance?
    – jc_mc
    Commented Dec 20, 2019 at 15:29
  • no... I only have 1 email defined within the data extension Commented Dec 20, 2019 at 15:33
  • Can you also have a check on re-entry setting! ... and also make sure they are NOT unsubscribed! Commented Dec 21, 2019 at 17:21

2 Answers 2

3

We had a similar issue. Certain test emails failed without a clear explanation in the error. In our case it was for an internal test email address with 'webmaster@...' prefix.

Those are automatically blocked by the default spam filter in marketing cloud. A complete list can you find here: https://help.salesforce.com/articleView?id=pardot_admin_role_based_email_address.htm&type=5

If that's the case in your situation, you can ask an exception for your "List Detective" filter by contacting support.

1
1

Finally I opened a case in Marketing Cloud and the issue was due to:

This error is logged when there is a value in the attribute in All subscriber which does not match with the value coming from the sales cloud.

There was an attribute without enough length and for that reason the values didn't match. Changing the size the issue should disappear.

Anna

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .