3

I have issue while creating a project using either SFDX: Create Project or SFDX: Create Project with Manifest command. I don't receive any error but the project is not created. The variable path is set.

  • VS Code version: 1.41.0 (user setup)
  • Salesforce CLI version: 7.36.0
  • Node.js version: 12.4.0
3
  • Did you get any error? Commented Dec 13, 2019 at 7:47
  • Please can you send the exact command you use, + the project-scratch-def file, + the error ? Commented Dec 13, 2019 at 10:11
  • I am using SFDX:create project then i select standard after that i give project name and hit enter . after hit enter nothing happened .No error nothing
    – fawad khan
    Commented Dec 16, 2019 at 4:44

5 Answers 5

0

https://github.com/forcedotcom/salesforcedx-vscode/issues/1840

You didn't specify the error, but I'd suggest making sure you update. There was a known issue in the github (linked above) that now has a fix that sounds like you might have run into.

1
  • There is no error but the problem is project not creating When i enter sfdx:create project command then i select standard then project name after that when i hit enter nothing can happen
    – fawad khan
    Commented Dec 16, 2019 at 5:10
0

i also had the same issue but this command worked for me try this to create the project

sfdx force:project:create --YOURPROJECTNAME
1
  • The correct command is sfdx force:project:create --projectname myProjectName
    – Alberto
    Commented Nov 1, 2022 at 14:26
0

For MacBook Pro OS (I have macOS Big SUR).

So the issue that I have found is this:

I can get to the commands on the Terminal window:

lightning-conference % sfdx --command
         

But I could not see any commands in the Visual Studio Code.

I also re downloaded nodejs, Salesforce CLI and git.

Then again Visual Studio Code, which I moved that into my /Applications folder.

NO JOY! :-(

So I looked at the Environmental variables in my Terminal using % printenv to see if there was something in the PATH but it looked ok. Nothing obvious there.

Results:

% printenv
TERM_PROGRAM=Apple_Terminal
SHELL=/bin/zsh
TERM=xterm-256color
TMPDIR=/var/folders/jp/pjh7sl5133lbmfqxm0nc698h0000gp/T/
TERM_PROGRAM_VERSION=440
TERM_SESSION_ID=96BE8546-FB6B-4AAB-87A0-A9BB80454F9A
USER=xxxxx.xxxx
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.ZgaqhoiZcc/Listeners
PATH=/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/share/dotnet:~/.dotnet/tools:/Library/Frameworks/Mono.framework/Versions/Current/Commands
__CFBundleIdentifier=com.apple.Terminal
PWD=/Users/xxxxx.xxxx/lightning-conference
XPC_FLAGS=0x0
XPC_SERVICE_NAME=0
SHLVL=1
HOME=/Users/xxxxx.xxxx
LOGNAME=xxxxxx.xxxx
OLDPWD=/Users/xxxxx.xxxx/lightning-conference
LANG=en_GB.UTF-8
_=/usr/bin/printenv

(BTW This reading from Himanshu Aggarwal about setting environmental variables is great)

So I decided to download the full heavy client from Microsoft Visual studio.

And then again reinstalled the Visual Studio Code.

THAT worked for some reason. Must have cleared the pipes somehow.

I do have 2 Visual studio apps now but will delete the heavier one once I am sure all works

enter image description here

1
  • Further to what I posted earlier, I also found a simpler answer. In the Folder that you have your Lightning Project(s), make sure that you copy and add the "sfdx-project.json" file in that root folder, if it is not there. Hope this makes sense. What I think it does is open up the extra SFDX Command in the VS SFDC extensions. Commented Jun 20, 2021 at 17:36
0

I had this issue just now. It seems like VSCode had an issue with opening file dialogs, since when I selected "open folder" it wouldn't open that either. I restarted the app, resized it a bit, maximized, clicked "open folder" again and the dialog appeared. It then also started working for the sfdx project creation command.

0

This is for Mac OS Go to Terminal in the VS Studio IDE (I tried this in the core IOS Terminal but that did not work for some reason. I think it is the relatonship between VS and the SFDX CLI package. I also tested the SFDX Authorise command directly in the IOS Terminal and it worked.)

Run these commands one by one on the VS Studio Terminal

sudo rm -rf /usr/local/sfdx

sudo rm -rf /usr/local/lib/sfdx

sudo rm -rf /usr/local/bin/sfdx

sudo rm -rf ~/.local/share/sfdx ~/.config/sfdx ~/.cache/sfdx

sudo rm -rf ~/Library/Caches/sfdx

sudo rm -rf /usr/local/sf

sudo rm -rf /usr/local/bin/sf

Then go to the VS Command and

SHIFT/COMMAND/P

SFDX: CREATE PROJECT WITH MANIFEST

Then you get the build for the Standard Project Template (default)

This auto restarts the EXTENSIONS in VS Code

For some reason, you need to reinstall the CLI

Starting SFDX: Refresh SObject Definitions

16:30:57.341 sfdx sobject definitions refresh Processed 16 Standard sObjects 16:30:57.375 sfdx sobject definitions refresh ended with exit code 0

Starting SFDX: Open Default Org

16:32:17.753 sfdx force:org:open 16:32:17.755 sfdx force:org:open Salesforce CLI is not installed. Install it from https://developer.salesforce.com/tools/sfdxcli

Starting SFDX: Authorize an Org

16:35:55.514 sfdx force:auth:web:login --setalias pandaOrg --instanceurl https://login.salesforce.com --setdefaultusername 16:35:55.514 sfdx force:auth:web:login --setalias pandaOrg --instanceurl https://login.salesforce.com --setdefaultusername Salesforce CLI is not installed. Starting SFDX: Authorize an Org

16:36:21.861 sfdx force:auth:web:login --setalias vscodeOrg --instanceurl https://login.salesforce.com --setdefaultusername 16:36:21.861 sfdx force:auth:web:login --setalias vscodeOrg --instanceurl https://login.salesforce.com --setdefaultusername Salesforce CLI is not installed.

Starting SFDX: List All Aliases

16:36:41.370 sfdx force:alias:list 16:36:41.371 sfdx force:alias:list Salesforce CLI is not installed. I

Once you do that, you can amend you code that you need and the VS Studio extensions should be enabled automatically. If not go to the VSStusio Extensions menu and enable the Salesforce Extension Pack.
You should be ok

1
  • Question was, why a project-create failed. Your approach is eradicating much of the original installation (are you sure a series of sudo rm is the best approach?), potentially taking project caches and other stuff with it, then reinstalling. I assume you started out with the exact same problem OP described two years ago. Had you tried a simple update of the VSCode plugin and sfdx? Commented Oct 8, 2022 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .