1

I have a simple flow to assign owners for a Account. Simple Flow

the flow is filtering the records using a custom field GP_Salesperson_id__c on the Account object = custom field on the user GPSalesUser__c and updating the Account Owner to equal the users id.
Update Records panel However when I run the flow in debug it runs with no errors and there are no records updated, when I run a SOQL with the same filter none of the errors are changed.

  • in debug, does the get records element return a User record? – cropredy Dec 5 '19 at 23:58
  • Yes It did here is the debug output. – Herb Williams Dec 6 '19 at 4:31
  • PassedUserId = 0051b000001il2vAAA FAST LOOKUP: get_the_user Find all User records where: Id Equals {!PassedUserId} (0051b000001il2vAAA) Sort records by: Name (Ascending) Store the values of these fields in get_the_user: Id, GPSalesUser__c, Name Result Successfully found records. – Herb Williams Dec 6 '19 at 4:32
  • it also found the accounts, UPDATE RECORDS: Update_Accounts Find all Account records where: GP_Salesperson_ID__c Equals {!get_the_user.GPSalesUser__c} (HALTER) Update the records’ field values. OwnerId = {!get_the_user.Id} (0051b000001il2vAAA) Result All records that meet the filter criteria are ready to be updated when the next screen, pause, or local action is executed or when the interview finishes. – Herb Williams Dec 6 '19 at 4:38
  • I don't see any accountIds. They would start with 001 – cropredy Dec 6 '19 at 5:20
1

The key issue is you have to update using an Account ID so you will need to first select the records using a Get Records to select the record you what to update, after that you need to Assign the values for the records, then Update the Records using the Account ID (see the image below. the working flow

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.