0

I have created a permission set.

The permission set does not have access to any apex class:

enter image description here

Enabling all classes in the permission set:

enter image description here

Getting the below error:

enter image description here

I can enable the permissions for classes by enabling those in patches or retrieving the metadata file and enable the classes in the file then deploy.

I followed this link, to insert record using Workbench to enable access.

But the CSV is not getting inserted successfully:

enter image description here

What is the quickest way to enable all Apex classes in the permission sets?

2
  • What is the error in case of bulk api insert?
    – ManishG
    Dec 4, 2019 at 13:33
  • in general, only the apex classes that are invocable, rest, webservices, ... need to enabled to users so this requirement is overkill
    – cropredy
    Dec 4, 2019 at 17:04

1 Answer 1

0

I got class names using SOQL.

SELECT Name FROM ApexClass

Using workbench:

enter image description here

Put those classes in the below structure:

<classAccesses>
    <apexClass>ClassName</apexClass>
    <enabled>true</enabled>
</classAccesses>

And deployed using meta-data.

Though this is not what I would prefer but this is what I had.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .