1

I installed an SFDX plugin to help with data loading, but the version installed with sfdx plugins:install etcopydata installs an older version with some missing functionality. Running sfdx plugins:update etcopydata doesn't update anything, so I decided to try installing from GitHub.

Per the readme's instructions, I cloned the repo and linked the plugin. I didn't get any errors, but when I ran sfdx plugins it said that none were installed.

README Install

I've tried this install method fixing the vulnerabilities and by leaving them intact in case the audit fix wrote over something important. Neither makes a difference.

Running sfdx plugin:install -h (and reading a StackExchange post) shows that you should be able to install directly using a GitHub link. Installing this way seemed successful at first, but running sfdx plugins again showed no installed plugins.

URL Install

I tried to do a little more Googling, but haven't found any answers.

1

For our case it was necessary to compile the project with yarn, before linking it.

1 Install Yarn.

2 Open a commandline in the plugin folder

3 run yarn

4 run sfdx plugins:link .

| improve this answer | |
  • Thanks for the answer! There was a minor hitch, but this was definitely the solution. If anyone in the future has this issue, and is working from a Windows machine, make sure you update the ETCopyData package.json in the root folder. At a few points it's trying to rm -rf several files, but rm -rf is a Linux command, so it'll error out. If you have npm installed, just replace all the rm -fs with rimraf. – Ryan Dinesman Dec 4 '19 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.