0

I'm a newbie.

I have a custom object "transaction__c" and looking in the workbench I have many fields, but doens't show the field "response_c"

list of fields in workbench

, but in the object have him image of field in the object

With this I made a query:

SELECT Response__c, name FROM Transaction__c where name ='test';

I execute the query and the return is: return of the query is: No such column 'Response__c' on entity 'ServiceTransaction__c'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

  • 1
    1. Can you confirm that the field actually exists on the object? In Salesforce go to Setup > Object Manager > find your object > in the 'Fields & Relationships" for the object verify that the field is there. 2. If the field really exists, check if your user's profile has access to that field. – Eduard Nov 29 '19 at 18:49
  • 1
    Also double-check that you have connected workbench to the same org that you used to inspect the object model. – Phil W Nov 29 '19 at 20:28
  • 1
    Your OP says Transaction__c yet error message is about ServiceTransaction__c – cropredy Nov 30 '19 at 1:02
2

Check the FLS for that field.

Setup --> Object Manager --> transition__c --> response__c --> Set Field-Level Security

Make sure that field is Visible to your profile

  • Thanks guy, u r the best. – Erick Mori Dec 2 '19 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.