1

I'm trying to set up a filter to manage a component visibility in a flow's screen component. In particular, I want the field to be available to the user for the insert of data only when a particular field's value is equal to 50.

For this purpose, I have created in the flow a Number variable named "CodiceFase", and I have assigned to it the value retrieved from the field of interest, thanks to the record Id (I check the correctness of the assignment with a Display Text component in the same screen).

Nevertheless, when I launch the flow the field is never visible, even if CodiceFase is correctly set to 50. If instead I use a Text variable in the condition for the component visibility, for example using another field's value to perform a similar check, everithing works as intended (I have checked the option "Enable Lightning runtime for flows" in Setup -> Process Automation).

Even stranger, the very same condition "{!CodiceFase} Equals [an integer number]" works perfectly in a previous Decision component of the flow.

For this reason I think the problem could lie somehow in the fact that I'm using a Number variable in the condition, but I am unable to figure out what I'm doing wrong.

Flow's Screen component with the non-working condition

The same condition works perfectly in a previous flow's Decision component

The field of interest isn't shown during runtime even if the variable CodiceFase is correctly set to 50

  • Have you tried 50.0 instead of 50? – notmyf4ulty Nov 28 '19 at 12:26
  • Yes, sorry for not specifying it in my question. I have tried 50.0, 50.00... – ARWarrior Nov 28 '19 at 13:31
0

You can achieve it by using a proxy formula variable. This is my test flow:

enter image description here

In Get Account element I retrieve the record from the Lightning Page with only one additional field - TestNumField__c which I use to control the visibility of one of Test Screen's components:

enter image description here

enter image description here

Here's the defined formula variable:

enter image description here

Which I use for setting component's visibility:

enter image description here

The final efect (I also put two debug text fields there as well):

enter image description here

  • Thank you for your suggestion, but I'll wait to mark it as answered. In fact I still don't understand why my condition doesn't work in the screen component, even if the very same logic works fine in a previous decision component. From a logical point of view the only difference between your and mine approach is the fact that you use a Boolean variable instead of a Number. If no other solutions/explanations will be produced, I'll proceed with the confirmation of your answer. – ARWarrior Nov 29 '19 at 9:21
  • @ARWarrior That's weird your way does not work, tried that too. I also encountered another issue - sometimes when trying to set up the visibility, after putting a constant/variable to the condition and clicking "Done" the formula was in a form of {!TestNumField} equals Null, where there should be 50 in place of Null. Did you have such a problem as well? – notmyf4ulty Nov 29 '19 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.