1

We have a scenario wherein we receive characters like ԄԪԥñ¿¡ from a API. We then query on a object which has a field value equal to the response. It works for most of the languages but for some characters like 'ԥ' query returns 0 rows even after maintaining the characters in respective field of object.

Please find below code :

String data = 'ԄԪԥñ¿¡';
List<Demo__c> demoLst = [SELECT resp__c FROM Demo__c WHERE resp__c = :data];

I have tried with different combinations and came to the conclusion that whenever 'ԥ' occurs in a string , query doesn't return the records.

Also , there are few more characters which i'am not able to paste in the question. Any pointers?

6
  • this works fine for me: insert new Account(Name = 'ԥabcdefghi'); Account[] accts = [SELECT id, Name FROM Account WHERE Name = 'ԥabcdefghi']; If character is valid UTF-8, it should work fine – cropredy Nov 21 '19 at 22:52
  • Actually , same is not working for user object as well.What might be the issue? – Rohit C Nov 22 '19 at 6:45
  • @cropredy , I tried the code which you shared , it is not working in my org. Should i raise a case with salesforce? – Rohit C Nov 22 '19 at 8:54
  • Just to update on this question. This has been recognized as a issue in salesforce. – Rohit C Dec 15 '19 at 15:30
  • Please link to the Known Issue page once it has been created – cropredy Dec 15 '19 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.