2

I have created a package.xml and added opportunity object from my sandbox. Then I have created a sfdx package but while versioning the package I am getting error from business process values. Error- "Opportunity.Bundle Opportunity: Picklist value: Negotiation not found".  Note: My approaches: 1. I have tried to delete the business process metadata from my package but still different error is coming as its related to record types. 2. Tried to delete all values from business process, then also getting errors

Can any one help me on this. How to solve this?

2

You'll want to get the stage names:

sfdx force:source:retrieve -m StandardValueSet:OpportunityStage

You can then build your unlocked package properly.

| improve this answer | |
  • Thanks for your comments its fine now. – Ananga Nov 20 '19 at 17:28
  • Hi, I am facing same kind of issue in Case object as well. I ran the cmd sfdx force:source:retrieve -m StandardValueSet:status but its retriving the case status picklist field values. Could you please tell me what should I do? – Ananga Nov 22 '19 at 5:58
  • @Ananga It should be StandardValueSet:CaseStatus. You'll want to check the documentation for the proper names to use. They are case sensitive. – sfdcfox Nov 22 '19 at 13:03
  • thanks.. got it now – Ananga Nov 24 '19 at 9:51
  • I am facing one different error in case object while versioning the package.Error : "Case.Recordtypename: duplicate value found: <unknown> is a duplicate of the value in the record with the following ID: <unknown>" . I check all picklist values in recordtype and there is no duplicate values present. Could you please help me on this. What is the reason of the error. – Ananga Nov 24 '19 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.