4

A client recently went live with a Commerce Cloud website / Marketing Cloud integration. Marketing Cloud is sending a Shipping Confirmation triggered email.

The tracking link in the Shipping Confirmation email won't resolve properly because of the WAC string.

Is there a way to disable the WAC string for a specific link using AMPscript or by any other method? Any other potential workarounds?

1 Answer 1

7

Yes. Here's a workaround to prevent the addition of WAC parameters using AMPscript:

%%[ 
var @URL, @Link
Set @URL = "http://www.salesforce.com" 

Set @Link = Concat('<a href=',@URL,' alias="Link">Link Test</a>') 
]%% 

%%=v(@Link)=%% 
5
  • 1
    Seems like there should be double-quotes around the href value. And the v() function isn't necessary inside the concat(). Nov 11, 2019 at 21:03
  • @AdamSpriggs I literally copied and pasted from that "knowledge" article Nov 11, 2019 at 22:00
  • @AdamSpriggs I just tested both solutions with or without the v() function and double or single quotes and both resulted in the exact same output. Nov 11, 2019 at 22:06
  • 2
    No shade on your post, just calling it out. Nov 11, 2019 at 23:30
  • 1
    Thanks guys! I was having trouble getting this to work, but figured it out. I just wanted to share on here in case any other AMPscript noobs come across this post. IF you are pulling in your link from a DE like I am (%%TrackingURL%%), then setting the URL should look like this: Set @URL = TrackingURL (no quotes or percent signs) I'm sure this is obvious to you two, but that took me a little while to figure out. Nov 14, 2019 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .