1

I've tried creating a simple workflow to change the case status from "Resolved" to "Reopened" when a customer replied to the case. I've found a few guides online to do this but for some reason it doesn't appear to function.

Here is the workflow rules: enter image description here

And here is the workflow action: enter image description here

Debug log:

10:29:37.217 (217367041)|CODE_UNIT_STARTED|[EXTERNAL]|Workflow:EmailMessage 10:29:37.217 (231870417)|WF_RULE_EVAL_BEGIN|Workflow 10:29:37.217 (231915699)|WF_CRITERIA_BEGIN|[Email Message: 02s1D000000PBXs]|Email Message Test|01Q1D0000007b3K|ON_CREATE_ONLY|0 10:29:37.217 (235993912)|WF_RULE_FILTER|[Email Message : Is Incoming equals true] AND [Case : Status equals Resolved] 10:29:37.217 (236022204)|WF_RULE_EVAL_VALUE|false 10:29:37.217 (236029789)|WF_CRITERIA_END|false 10:29:37.217 (236047673)|WF_CRITERIA_BEGIN|[Email Message: 02s1D000000PBXs]|Email_Message_test3011D000000BSAn|01Q1D0000007azX|ON_CREATE_ONLY|0 10:29:37.217 (236230003)|WF_FORMULA|Formula:ENCODED:[treatNullAsNull]true|Values: 10:29:37.217 (236241493)|WF_CRITERIA_END|true 10:29:37.217 (236801664)|WF_SPOOL_ACTION_BEGIN|Workflow 10:29:37.217 (236838041)|WF_ACTION| Flow Trigger: 1; 10:29:37.217 (236844210)|WF_RULE_EVAL_END 10:29:37.217 (261839312)|WF_FLOW_ACTION_BEGIN|09L1D0000000sKi 10:29:37.217 (261899102)|WF_FLOW_ACTION_DETAIL|09L1D0000000sKi|[Email Message: 02s1D000000PBXs]|Id=09L1D0000000sKi|CurrentRule:Email_Message_test3011D000000BSAn (Id=01Q1D0000007azX) 10:29:37.217 (262376078)|WF_FLOW_ACTION_DETAIL|Param Name: myVariable_current, Param Value: ENCODED:{![treatNullAsNull]{!ID:this}}, Evaluated Param Value: {Entity type: EmailMessage, id: 02s1D000000PBXsQAO}|Param Name: myVariable_old, Param Value: {!old}, Evaluated Param Value: null 10:29:37.217 (267526558)|WF_FLOW_ACTION_END|09L1D0000000sKi 10:29:37.217 (267646688)|WF_ACTIONS_END| Flow Trigger: 1;

Would anyone perhaps know why this isn't functioning or know of an alternative method?

1
  • What did you do to test? It looks like it evaluated to false in the WF criteria. – Kris Goncalves Nov 1 '19 at 16:20
2

Figured out the issue. I didn't test by sending and replying to the Proxy email designated in the email-to-case setting. It also requires the setting of including the thread ID in the subject or body also located in the Email-to-case setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.