1

I have an issue when applying filters in a Data Extension for a few days ago. Basically it doesn't work.

For example, if I did a filter from a Data Extension adding the criteria 'Email is not null' it works but, if I add another filter like 'language equals to EN' it stops working properly, showing results that make no sense with the filters (empty email fields or the same count than the previous filter with just one criteria).

enter image description here

Have you ever experienced this kind of bug? I already opened a ticket to support but they are escalating it without any result.

  • What are the Data Relationships between your data extensions? Can you give a Screenshot of your filter conditions? There are some use cases where Data Filter does not work as expected.. – Rachid Mamai Oct 30 at 9:35
  • I already added a screenshot. There is no data relationship, just a simple filtered data extension (the issue happens with any data extension, not only when using the synchronized ones). I tried applying filter by filter but by the time I add a second criteria it stops working. – fromero Oct 30 at 9:44
  • Pretty strange. I've had problems with data filter when using Data Relationships. But what you are trying to do is very basic. In your case, i'll just wait for the supports answer. – Rachid Mamai Oct 30 at 10:22
  • Have you tried removing the OR condition altogether and utilizing the exists in filter operator with a CSV list of language__pc values (without any quotes)? – Adam Spriggs Oct 30 at 20:11
  • Yes, I tried that but I get the same number of records when adding different languages – fromero Oct 31 at 10:09
3

If you’re filtering a Sales/Service Cloud Synchronized Data Extension, and it seems that you are (some of the fields in your screenshot have __c), then you are experiencing the documented bug: Filtered Data Extensions created from Synchronized data extensions fail when using 2 or more fields in filter

Currently, the only possible workaround is to use SQL query instead of a filter.

You can read more here: https://success.salesforce.com/issues_view?id=a1p3A000000FmiYQAS&title=filtered-data-extensions-created-from-synchronized-data-extensions-fail-when-using-2-or-more-fields-in-filter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.