2

I am trying to use the new LWC Local Development Server.

I've run command:

sfdx update

So I know I am using the latest version of the CLI.

And I've installed the plugin:

sfdx plugins:install @salesforce/lwc-dev-server

And it seems to install fine:

Successfully validated digital signature for
@salesforce/lwc-dev-server. Finished digital signature check.
Installing plugin @salesforce/lwc-dev-server...

And then I authorised a Sandbox org.

But when I run the command to start the server:

sfdx force:lightning:lwc:start

I this this:

» Warning: force:lightning:lwc:start is not a sfdx command.
Did you mean force:lightning:lint? [y/n]:

When I run this command:

sfdx plugins

I get a result of:

no plugins installed

Questions

  1. Any ideas what I am doing wrong?
  2. How can I fix it / get it working?
1

You must use a Scratch org not a standard Sandbox.

System Requirements

Developer Hub-enabled org
Most recent stable version of Chrome, Firefox, Safari, or Edge web browser
Windows—Windows 7 (64-bit and 32-bit) or later
Mac—macOS 10.11 or later
Linux—Ubuntu 14.0.4 or later
Salesforce CLI

Reference

| improve this answer | |
  • I forgot to mention I had authorised a sandbox org. I've updated the question – Robs Oct 30 '19 at 14:28
  • I tried by Creating the project, authorize it to a Sandbox, then installed the server and then ran the command to start the server. I had no issues. Can you try to authorize first before installing the server ? – Anshul Agrawal Oct 31 '19 at 8:50
0

Also if you are on node and doing local development try to install dependencies using 'npm install' and try again .

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.