0

I am trying to create the Project from my terminal windows in VS code from running the command as below:

sfdx force:project:create -n "LWC Session"

Getting error as below :

{WARNING: apiVersion configuration overridden at "45.0" ERROR running force:project:create: Name must contain only alphanumeric characters.}

Please help me out for this.

6
  • 1
    Space (" ") character is not alphanumeric character
    – kurunve
    Commented Oct 28, 2019 at 15:40
  • 2
    that's not the issue here I can create a project with that name, seems like a config error for the cli.
    – Atlas Can
    Commented Oct 28, 2019 at 15:40
  • 1
    @AtlasCan indeed correct, I can create such a project
    – kurunve
    Commented Oct 28, 2019 at 15:46
  • 2
    Should i Uninstall the CLI and install again?? Commented Oct 28, 2019 at 15:46
  • @AtlasCan actually after updating sfdx into 7.30, I can not anymore, so seems to be recent change
    – kurunve
    Commented Oct 28, 2019 at 15:47

1 Answer 1

1

sfdx force:config:set apiVersion=46.0 can you run this and try again?

2
  • C:\Users\ABHIJEET KUMAR>sfdx force:config:set apiVersion=46.0 WARNING: apiVersion configuration overridden at "45.0" === Failures NAME MESSAGE ────────── ──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────── apiVersion This directory does not contain a valid Salesforce DX project. Add the --global flag to set config outside of a project. Getting this error Commented Oct 28, 2019 at 16:10
  • 1
    Yes it got created Without the Space Between "LWCSession" Commented Oct 28, 2019 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .