0

I have the following problem in Commerce Cloud's B2B Commerce (formerly CloudCraze) 4.11:

A guest user (Anonymous) can browse and see products on the PLP and PD pages.

A logged in user, however, cannot do so.

The logged in user has the appropriate profile permissions as per the documentation, plus the necessary objects are given Read Only rights in OWD. The logged in user is linked to the default PortalAccount which belongs to the PortalAccount (Account Group). All users are using the same currency and localisation config.

CC 4.11 Docs

Storefront Community User Profile Permissions

  • 1
    Welcome. I'm not familiar with CloudCraze, but I think it would be helpful if you linked what documentation you're referring to and what you did to give "appropriate profile permissions". – Kris Goncalves Oct 28 '19 at 14:29
  • @KrisGoncalves I have added the links :) – Elie Nassif Oct 28 '19 at 14:36
  • You are referring to the B2B Commerce module of Commerce Cloud, right? – David Cheng Oct 28 '19 at 15:10
  • @DavidCheng Yes Sir – Elie Nassif Oct 28 '19 at 15:33
0

Turns out that it is a currency problem, although I thought I had configured it properly (and I did).

Company currency = EUR User Currency = EUR Account Currency = EUR Pricelist Currency = EUR Storefront Default AND Active currency = EUR

BUT, after digging into a long session of debugging and reviewing the logs at the registered user level, it turns out that the Apex classes in B2BCommerce were returning 0 products because the pricelist currency did not match the user currency.

Actually, when you install the managed package, a new custom field CC_Currency is added to the User object. This field however is not required and does not appear on the user profile and users' layouts. Plus it is not automatically filled.

Therefore the mentioned CC_Currency field will remain empty and will affect the products available to your users.

Apparently, if the field is empty, it is hard coded that 'USD' replaces the empty value, instead of using the related accounts' currency or any other currency for that matter.

I was able to resolve the issue by adding the field to the layout, and updating it to EUR for my users.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.