2

I'm using the following command to install Salesforce CLI in my Automated CI in Azure DevOps.

npm install sfdx-cli --global

It was working fine till last Friday and now we are facing the following error:

salesforcedx: No matching version found for salesforcedx@47.3.4
at pickManifest (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-pick-manifest\index.js:101:11)
at fetchPackument.then.packument (C:\Program Files\nodejs\node_modules\npm\node_modules\pacote\lib\fetchers\registry\manifest.js:24:14)
at tryCatcher (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\util.js:16:23)
at Promise._settlePromiseFromHandler (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:512:31)
at Promise._settlePromise (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:569:18)
at Promise._settlePromise0 (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:614:10)
at Promise._settlePromises (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\promise.js:694:18)
at _drainQueueStep (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:138:12)
at _drainQueue (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:131:9)
at Async._drainQueues (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:147:5)
at Immediate.Async.drainQueues [as _onImmediate] (C:\Program Files\nodejs\node_modules\npm\node_modules\bluebird\js\release\async.js:17:14)
at runCallback (timers.js:705:18)
at tryOnImmediate (timers.js:676:5)
at processImmediate (timers.js:658:5)

Can someone tell me why this error occurs? Also, I could see the latest salesforcedx version is 47.3.3. Not sure why it is checking for version 47.3.4

2

I ran into this same error trying to update sfdx locally.

I think this is indeed an issue with the latest release of sfdx-cli on npm (version 7.30.11)

I thought running sfdx plugins:install salesforcedx would do the trick, but that updated the salesforcedx plugin to 47.3.6 (according to the npm listing for the salesforcedx plugin the released versions went straight from 47.1.5 to 47.3.6)

Until this is sorted out I think you'll need to point specifically to the prior version of sfdx-cli via npm install -g sfdx-cli@7.28.7

EDIT: Looks like version 7.30.12 of sfdx-cli was just released about an hour ago, I am now able to run npm install -g sfdx-cli without issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.