I was just about to access a custom Visualforce page in my managed package dev org when Salesforce returned the message:

Your organization has been disabled
Salesforce.com has disabled access to the system for your company. Please contact support@salesforce.com for more information about this error.

This was most concerning, as I need that Org to release the managed package for a client who wouldn't be impressed while I tried to resolve the issue with support.

Any attempt to reconnect to the org gave the same message. It appeared to resolve itself about 5 minutes later while I was writing an email to support.

Does anyone know what might have caused the message?

1 Answer 1


Mystery solved. I had requested the Multi-currency support be enabled in my Org several days ago.

Implications of Enabling Multiple Currencies
Work with your salesforce.com representative to determine the best time for multi-currency enablement. The enablement process temporarily locks your organization, preventing any integration processing and user logins. The lockout duration depends on the data space used by your organization. Source

Just to be clear. This wasn't Salesforce's fault. They were doing exactly what I asked them to do and I had forgotten the implications that I agreed to beforehand in the support case.

  • Too bad you couldn't request a specific time period for that work.
    – Mike Chale
    Feb 18, 2014 at 21:02
  • 1
    In hindsight I should have tried specifying a preferred time in the case. To be fair they do ask that you acknowledge that your org will locked out during the migration when you open the case. My bad for not remembering what I asked support to do 5 days ago. Feb 18, 2014 at 21:10
  • I hope people aren't voting this up so enthusiastically to highlight that I screwed up :) Feb 18, 2014 at 21:23
  • 2
    Just be careful when doing this in a prod org with lots of data. It took us down for 11 hours, but we fortunately were aware of the timeline and planned it for non peak hours.
    – drakored
    Feb 19, 2014 at 3:13
  • 2
    Just discovered that this sometimes happens when refreshing a sandbox as well and it takes a few minutes to re-index.
    – mpusto
    Aug 29, 2014 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.