7

I have a scratch org that I'm trying to implement the support console with. When I try to pull the code using sfdx, I'm getting the following error:

Entity of type 'CustomApplication' named 'Case' cannot be found

I tried putting CustomApplication/** and CustomApplication/Case in the .forceignore file and tried to pull and still get the same error.

Has anyone had to deal with something like this?

5 Answers 5

13

This is a bug I feel somewhere in the sfdx cli and one needs to bring it attention to Salesforce on this.

The following is a workaround that did actually work for me .

  • I created an application named 'case' in my scratch org

  • Run `sfdx force:source:pull.

  • Add the folder path of the application in .gitignore and in .forceignore files.

Note that with this workaround I was able to get past this issue.However it is definitely a bug in salesforce CLI which I request you raise a support case.

Update

Any thing you want to exclude when you run force:source:pull you can do so by deleting the Member from Source Member object.

Use Developer console to execute below query

Select Id, MemberName From SourceMember Where MemberType = 'CustomApplication

and Delete it in the Dev console.

5
  • 2
    Thank you so much Mohith for giving this a try. I actually ended up doing this as well and was able to get past my issue.
    – Scott
    Oct 21, 2019 at 16:27
  • 1
    This seems to be happening again. I just experienced it except with "Contact". I created a SFDX project, created a LWC, made it available for Contact record pages. I created a Contact flexipage, added the LWC for it, and activated the flexipage as org-wide default. When I tried pulling source I got: Entity of type 'CustomApplication' named 'Contact' cannot be found
    – Charles T
    Jan 13, 2020 at 21:45
  • @Charles T it's better to report it to the sfdx-cli repo Jan 14, 2020 at 0:49
  • 1
    Thanks. Issue link: github.com/forcedotcom/cli/issues/205 and dcarroll included the suggestion of deleting the SourceMember entry responsible for the error.
    – Charles T
    Jan 14, 2020 at 13:25
  • Just a quick note on the "update" section; that query requires the Tooling API checkbox to be checked if running from the Dev console's Query Editor.
    – torpy
    Feb 11, 2021 at 15:52
7

Just happen to me too. Seems like its a known Issue - Only way I managed to remove this error was remove/delete the SourceMember.

sfdx force:data:soql:query -q "Select Id, MemberName From SourceMember Where MemberType = 'CustomApplication'" -t

Then Delete with the result Id.
sfdx force:data:record:delete -s SourceMember -i 0MZ1** -t -u orgAlias

1
  • thanks, this worked for me
    – Sree
    Apr 28, 2020 at 16:53
4

An alternate (as the OP was attempting) would be to add to the .forceignore file. I believe this is the entry that's needed (though the syntax is confusing and case-sensitive... with next-to-zero docs)

Case.CustomApplication
6
  • Thanks for following up Todd!
    – Scott
    Nov 22, 2019 at 18:10
  • It seems this has been fixed now but if not then we need to raise it again. Nov 23, 2019 at 14:32
  • @MohithShrivastava What is the final solution for it? Did you get any? Or still we have to query and delete the source member or create an app in salesforce, then pull and then delete? Please share the forceignore details if this can be skipped Dec 5, 2019 at 12:13
  • What I know is this should no more be issue.It is fixed with latest version of cli Dec 5, 2019 at 14:37
  • what is the exact line here ? **/Case.CustomApplication ? Dec 9, 2019 at 5:36
4

After trying many variations, I've found that CustomApplication does not follow the documented pattern of <api name>.<metadata type> for any variation of capitalization, including

Lead.CustomApplication
Lead.customApplication
Lead.customapplication
lead.customapplication
# grasping at straws
*Lead.CustomApplication*

However, using app as the metadata type name does work, e.g.,

Lead.app 

Tested with cli version [email protected].

1
  • Yes... I believe for the stuff you want to ignore that is remote you can use the `<api name>.<extension-as-would-be-in-the-repo>, (less any "-meta.xml") e.g if you had a custom application in the repo it would be in a file called "Lead.app-meta.xml", and could be ignored with "Lead.app" Mar 6, 2020 at 16:52
4

I ran onto the following error:

ERROR running force:source:pull:  Entity of type 'ProfileSessionSetting' named 'HR2day_Standaardgebruiker_profileSessionSetting1615531712750' cannot be found

The mechanism suggested by @sfdxbomb did not solve the problem. I resolved it by hacking the file .sfdx/orgs/[email protected]/maxRevision.json and removing the sections mentioning the entity.

2
  • Same for me - thanks
    – edralph
    Mar 29, 2021 at 13:43
  • Your fix worked for me Oscar. Thanks!
    – Keith C
    Sep 15, 2021 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .