1

I'm trying to do the Apex Replay Debugger trailhead, which requires JDK 8. When I install the JDK on my Mac, the installer tells me it went into /Library/Java/ directory. However, when I look in that directory (Finder | option+Go | Library, I don't see a /Java subdirectory anywhere.

It didn't err out; the installer worked with no errors. It just doesn't seem to have done anything. And, of course, when I reference that Java directory in VSCode, it can't find it.

Anybody else having this issue? Where is the JDK being installed, if at all?

0

Just to let you know, I solved the problem, even though I wasn’t able to get the JDK to install via Oracle’s OSX .dmg installer…

I downloaded JDK 11.0.4 as a tar.gz file, to Mac's Downloads directory. Then I used the Mac Archive utility to unzip it, created a /Java directory under Library, then drag/dropped the unzipped jdk to /Library/Java.

Then in VSCode, go Code | Preferences | Settings | search for “apex java.” The first thing that should come up is “salesforce-vscode-apex.java.home. Then just enter the path to your newly unzipped (and dragged) jdk: /Library/Java/JavaVirtualMachines/jdk-11.0.4.jdk/Contents/Home.

Once I did all that, the debugger worked. Still don’t know why Oracle’s .dmg installed kept telling me it installed when it clearly didn’t.

Just thought I'd let you know in case anyone has the same problem.

Eric

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.