0

I have built an unmanaged package and was able to deploy it to several orgs.

Unfortunately at the current Service Cloud org I get the following error:

In field: object - no CustomObject named WorkFeedbackRequest found XX_Admin: In field: object - no CustomObject named WorkFeedbackRequest found

XX_Admin is a permission set. The object WorkFeedbackRequest is neither in the source org nor the destination org available and is not needed and used by my package. I have found out, that this object may have something to do with work.com settings, why I already tried to switch work.com off and on. I also tried to create the object, but nothing helped.

Do you have any advice on this error?

0

I had intensive contact with Salesforce Support the last days. The solution or workaround which might also help others, which was provided is the following:

ROOT CAUSE OF THE ERROR even if Work.com components were not used during the package development, the package installation was failing later on missing Work.com features.

Your developer org has active Work.com licenses, which is rare with dev orgs and the target org doesn't have them.

BELOW ARE THE 2 WORKAROUNDS.

  1. To recreate the package in an org without Work.com licenses. To move the package metadata, you can use Force.com IDE. This workaround can fix the issue if the package is not installed in any customer orgs yet. Since the package is installed in subscriber orgs, we would not suggest this workaround: Due to the namespacing, any schema within a package that has to be moved over to a new package will require their subscribers to uninstall and re-install the new package, losing all their data.

  2. You can contact your ISV partner manager to clarify and remove the Work.com licenses.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.