1

I am using 1.38.1 version of VSCode and i have done

"http.proxyStrictSSL": false

I am still getting error

Error: unable to get local issuer certificate

i tried in my personal laptop. Now getting following error

 warning @salesforce/lwc-dev-server > @lwc/style-compiler > cssnano > autoprefixer > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
warning @salesforce/lwc-dev-server > @lwc/style-compiler > cssnano > postcss-merge-rules > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.hed digital signature check.
warning @salesforce/lwc-dev-server > @lwc/style-compiler > cssnano > postcss-merge-rules > caniuse-api > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
warning @salesforce/lwc-dev-server > @lwc/style-compiler > cssnano > postcss-merge-rules > postcss-selector-parser > flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
warning @salesforce/lwc-dev-server > @salesforce/command > @oclif/test > fancy-test > @types/nock@11.1.0: This is a stub types definition. nock provides its own type definitions, so you do not need this installed.
warning @salesforce/lwc-dev-server > @salesforce/core > @salesforce/ts-sinon > sinon > @sinonjs/formatio > samsam@1.3.0: This package has been deprecated in favour of @sinonjs/samsam
error An unexpected error occurred: "https://registry.yarnpkg.com/@salesforce/lwc-dev-server-dependencies/-/lwc-dev-server-dependencies-1.0.47.tgz: ESOCKETTIMEDOUT".
C:\Users\Sidhartha Mohapatra\AppData\Local\sfdx\client\7.27.0-714f62f9c1\node_modules\yarn\lib\cli.js:78070
    compromised = compromised || function (err) { throw err; };
                                                  ^

Error: Unable to update lock within the stale threshold
    at options.fs.utimes (C:\Users\Sidhartha Mohapatra\AppData\Local\sfdx\client\7.27.0-714f62f9c1\node_modules\yarn\lib\cli.js:77992:66)
    at FSReqWrap.args [as oncomplete] (fs.js:140:20)
Installing plugin @salesforce/lwc-dev-server... !
Error: yarn add @salesforce/lwc-dev-server@latest --non-interactive --mutex=file:C:/Users/Sidhartha Mohapatra/AppData/Local/sfdx/yarn.lock --preferred-cache-folder=C:/Users/Sidhartha Mohapatra/AppData/Local/sfdx/yarn --check-files exited with code 1
    at ChildProcess.forked.on (C:/Users/Sidhartha Mohapatra/AppData/Local/sfdx/client/7.27.0-714f62f9c1/node_modules/@oclif/plugin-plugins/lib/yarn.js:31:28)

has anyone faced this issue and tried any workaround

1 Answer 1

2

found the solution .. Just need to trick Node that there is a certificate present, if people are working in office network..

Downloaded the certificate -

https://www.digicert.com/CACerts/DigiCertHighAssuranceEVRootCA.crt

Ran the below command -

npm config set cafile /path/to/DigiCertHighAssuranceEVRootCA.crt

after this i was able to install within corporate network

2
  • Some more details would make this a better answer. How, precisely, do you trick node into thinking there is a cert? Good answers are those where other people can understand and apply them themselves (without needing to dig around for other resources).
    – Derek F
    Oct 22, 2019 at 11:33
  • updated my answer.. Oct 23, 2019 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.