I'm trying to use Excel Connector to import data into Salesforce. A colleague of successfully used it before and now I want to finish the job. Our Salesforce database already contains all our clients. When I connect with Excel Connector using the server URL https://www.salesforce.com/services/Soap/c/13.0 the list of accounts seems to be part of a sandbox database.

Is there maybe some user setting in Salesforce for my account that is set wrong?

  • 1
    If you're using the same computer that your colleague was using then there might of been a registry change that allowed them to connect to a Sandbox. Check HKEY_CURRENT_USER\Software\Salesforce.com in the registry to make sure there is no key called "Excel" there – BarCotter Feb 17 '14 at 15:17
  • There is no such key present – Wouter Feb 17 '14 at 15:27

That is the correct setting for connecting to a Production org.

If you did want to use it with a sandbox you would click advanced and change it to https://test.salesforce.com/services/Soap/c/13.0

Are you using the correct username and password for production? Have you tried forcing a logout first (Force.com Connector | Logout Session)?

The credentials that you use to login to production should be different (username) from the credentials that you use to login to sandbox.

To double check that you are logged into production through the Force.com connector, first logout, then login again (e.g. by creating a table query). Then, in Salesforce production look at the user record and you should see the login history

enter image description here

If you see this "Apex Office Toolkit" under your production user then you are logged into Production.

  • I know it is the correct setting for a production database, BUT it does not connect to our production database. Are there specific user settings for a 'production' user? I've not enabled 'Development Mode' in the user settings. – Wouter Feb 17 '14 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.