0

When we try to get "fewer updates" or "All Updates" api call needs to be invoked which is supported in version 29. Maximum version for 'user' access in our current sandbox is: 28. We Changed the version of our current page and controller to 29.0 but still when we try to run the page we get the below error

This object was built in version 29.0. Maximum version for for 'user' access is: 28.0 An unexpected error has occurred. Your solution provider has been notified. (ConnectApi)

It seems currently we do not have access to the requisite Api, may be in later version it will be available for us. However we are able to get the records when we run them from developer console. Any suggestions?

Thanks in advance.

  • The "user" property being referenced in the error message is the ConnectApi.MentionSegment.user property, which is only available in v28.0. It seems like there's an object that was constructed using v29.0, and then attempted to be read using v28.0 somehow. Are you able to provide any sample code to repro the error? – alouie Feb 21 '14 at 18:27
0

I got this resolved, here is the answer for reference.

With the release of winter 14 they replaced User Property with record property and the same is quoted in below from the above link.

ConnectApi.MentionSegment

This class has a new record property which is a ConnectApi.ActorWithId object that represents the mentioned user or group. The record property was added because you can now mention groups in addition to users. As of version 29.0, use the record property instead of the user property, which is no longer available. In versions earlier than 29.0, if the mention is not a user, the mention is in a ConnectApi.TextSegment object.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.