0

I am trying to create project workspace using VS Code. I am using SFDX: Create Project with Manifest command. After executing, it is creating folder for my project with all default files in VS code. But when I am trying to Authorize an Org, I don't see that command in the palette. I tried all ways. Like uninstalling everything including CLI but it is not working. Please advise. enter image description here

  • What java version you have. Is your classpath shows sfdx? are you able to run the authorization from the command prompt? – Avijit Chakraborty Oct 4 '19 at 3:22
0

You will not see the option to authorize the org when your extension does not activate when you open the VS Code.

The below pic shows only three options when I open the command palette. When you see the blue bar at bottom in left, it does not shows you weather you are authorized to an org or not. enter image description here

In the below pic, It does not give me the option to deploy components to org or retrieve it from org because extensions are not activated.

enter image description here

This pic shows extensions are getting activated if you focus on the blue bar at the bottom in left.

enter image description here

Once extensions are activated, I got the option to authorize an org. Generally, it takes a few minutes for auto-activation. enter image description here

  • Hi Sanket, thank you for your message. I can see 'No Default Org set' at the bottom left but whenever I am trying to authorize an Org by doing CTRL + SHIFT+ P , it does not show me option to authorize an org. I have added a snapshot in my original question. – salesforcewithfunforce Oct 4 '19 at 19:32
0

seems like extensions are not active for your org install the tools required then try again it will work.

  • Hi Akash, thank you for your message. I can see 'No Default Org set' at the bottom left but whenever I am trying to authorize an Org by doing CTRL + SHIFT+ P , it does not show me option to authorize an org. I have added a snapshot in my original question. – salesforcewithfunforce Oct 4 '19 at 19:32
  • Try to update the java min- 8 is required. Hope it helps. – akash Oct 7 '19 at 3:40
  • add the update JDK path in salesforce: apex – akash Nov 11 '19 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.